Setting up Environment

This article provides you with the information required before you start importing a LibGDX project.

LibGDX projects are built and managed with the Gradle build tool. This allows you to develop in almost any environment that takes your fancy, even if you are working in a team.

The 3 major java IDEs, IDEA/Android Studio, Eclipse and Netbeans are all supported, just make sure you have set them up correctly.


Setting up your Development Environment


Setting up Intellij IDEA/Android Studio

Minimum:

  • Java Development Kit 7+ (Must be JDK)
  • Intellij IDEA 2016+, (community edition is sufficient) Link
  • Android Studio, 2.2+ Link

Android:

  • Android SDK (If using IDEA) Link

iOS:

  • RoboVM OSS Intellij plugin (if using RobovmOSS) Link
  • Multi OS Engine Intellij plugin (if using Multi OS Engine) Link

Setting up Eclipse

Minimum:

  • Java Development Kit 7+ (Must be JDK)
  • Eclipse Mars+ with Buildship link

Android:

iOS:

  • RobovmOSS Eclipse plugin Link
  • Multi OS Engine plugin Link

Setting up Netbeans

Haha good one...

Command Line

Minimum:

  • Java Development Kit 7+ (Must be JDK)

Android:

  • Android SDK
  • Set the ANDROID_HOME environment variable, or use gradle.properties